OneFuse - Data too long for column

Problem 

When adding a new name into OneFuse, you will see a “Data too long for column” or “1024 Character Limit” error. Please upgrade to OneFuse 1.4, or contact support for a hotfix for your release.

Cause

This happens because there’s a character limit of 1024 on the naming data for each naming sequence


Affected Versions

  • OneFuse 1.1/1.2/1.3

Solution

Overview

We will need to SSH into the OneFuse Appliance and get into shell_plus to edit the naming data for the naming sequence.


OneFuse and Shell_Plus

As shell_plus is a debug tool for OneFuse and CMP appliances please contact CS if you require assistance.

  1. SSH into your OneFuse Appliance

  2. Once you’re logged in, you will need to get into Shell_Plus by entering this command → /opt/cloudbolt/manage.py shell_plus

  3. Now that you’re in shell_plus, you will need to run the below commands

    sequence = NamingSequence.objects.get(name="YOURNAMINGSEQUENCE”)
    sequence.naming_data

  4. The second command will return a python exception rather than the list of naming data proving that we have encountered this issue.

  5. Now run (note the _). This will return json data that will have been truncated. With this string you will need to repair the end of it by removing the partly truncated value and noting down this partial prefix so that the data can be re-added after installing the hotfix.

    sequence._naming_data
  6. Please copy this string to a text editor, remove the incomplete value being sure to add the closing '}'. If you need assistance reconstructing a valid json string, please contact CS.

  7. Run, the first command sets the naming data and the second command verifies the json is valid and can be parsed.

    sequence._naming_data = "{FIXED_JSON}"
    sequence.naming_data
  8. If the correct list is returned then proceed to save the sequence.

    sequence.save()

  9. This should return functionality provided no new naming prefixes are generated by your configuration.

  10. Now please urgently schedule and install the relevant update for your OneFuse platform:
    Upgrade to 1.4
    Hotfix for 1.2 and 1.3 available from Customer Success.


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