Unable to RDP to windows servers from cloudbolt

Problem 

Once you have deployed a windows server, you can not remote desktop to the server.

Once you click on Remote Desktop and new window/tab opens in your browser and you are presented with a disconnect error.

If you RDP from your laptop or another server, Remote Desktop does work as expected.

If you are unable to RDP to the server from any location then this article may not resolve your issue.


Cause

This is primarily caused by a local policy/group policy on the windows server named Network Level Authentication


Affected Versions

  • All versions at this time


Workaround

Overview

As this is a security setting we recommend speaking with your domain administrators and security team before making this change as it can be viewed as a security compromise.

To work around the issue, set the Require user authentication for remote connection by using Network Level Authentication to Disabled.

There are multiple ways you can achieve this and it will be down to your organization's requirements. One approach is through Group Policy and the other is to update through the local server.

If you have enforced this as enabled through group policy, modifying this on the server locally will see this be overwritten by group policy again.

Locate the Policy

  1. The policy is located in Computer Configuration → Administrative Templates → Windows Components → Remote Desktop Services → Remote Desktop Session Host → Security

  2. In Security, look for the Require user authentication for remote connection by using Network Level Authentication policy and click Disabled.

  3. Once the policy is applied to the server, you should be able to remote desktop to the server.

Additional information

No additional information


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