Session Expired Error on login - unable to access the platform

Problem 

Users/Administrators cannot log into the OneFuse Platform. User will receive an error prompt indicating Session Expired on the top banner.


Cause

This is caused by the OneFuse Platform system time not being synchronized to the NTP Servers causing the default session timeout to trigger and deny user login.


Affected Versions

  • OneFuse 1.0.+


Solution

Overview

Modification to the OneFuse platform may be necessary to synchronize the NTP service. Follow the steps below to confirm and restart NTP services.


SSH to the OneFuse Platform and check system time

  1. Connect to the OneFuse platform appliance over port 22 with Linux terminal software (ex: Putty)

  2. Run the following command and compare to the system time to the current time

    1. timedatectl
  3. If you see the NTP synchronized option as no, then follow the next section of steps

    1. NTP enabled: yes
      NTP synchronized: no

Modify the /etc/chrony.conf

  1. Navigate to /etc/chrony.conf and modify the list of NTP servers

    1. # Use public servers from the pool.ntp.org project.
      # Please consider joining the pool (http://www.pool.ntp.org/join.html).
      server 0.centos.pool.ntp.org iburst
      myNTPserver.mydomain.xyz
  2. Save the chrony.conf file and run the following command to restart the NTP services

    1. service chronyd restart
  3. Run the following command again to confirm the NTP services are restarted

    1. service chronyd status

  4. Run the following command to check the NTP services and confirm it is synchronized

    1. timedatectl
      
      Check for the following
        NTP enabled: yes
        NTP synchronized: yes


Confirm user login

  1. Attempt to log in once again to the OneFuse UI

  2. If login is unsuccessful, please submit a support request at the Cloudbolt Support Portal


Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.