Problem
Sovlabs integrations for Day 2 Operations via ServiceNOW CMDB items, SovLabs VM Tagging, or SovLabs Snapshot modules fail during execution. May appear as not functional in UI (for ServiceNOW Day 2 actions) or generic error in vRO logs. "Unexpected Error attaching tags to VM: null"
Cause
The issue is with a known VMware bug with the CAFE plugin in vRO. See the following KB: https://kb.vmware.com/s/article/71090
Affected Versions
All versions of SovLabs plugin
- SovLabs ServiceNow CMDB
- SovLabs VM snapshots
- SovLabs VM Tagging
Symptoms
- Provisioned catalog resources can not be loaded under the "Items" tab in thevCACCAFEplugin. Instead, "Error in plugin" message is shown.
- The java client has messages similar to:
- Finder methods for catalog resources are failing.
Solution
Overview
SovLabs integrations rely on the inventory of the vRA Host to perform actions. If this is not functional the modules above are impacted. Recommend performing vendor provided solution to return environment to functional state.
Apply Vendor provided CAFE plugin update.
Follow instruction at this URL: https://kb.vmware.com/s/article/71090
Double-Check account permissions on account used for vRA Host.
SovLabs account prerequisites found here: http://docs.sovlabs.com/latest/vmware-vra7x-plugin/getting-started/configure-vra/step-1-1/
- The Service Account user must be an:
- IaaS Administrator
- Tenant Administrator
- **The Service Account user must also have at minimum the roles of:**
- XaaS Architect
- Tenant Administrator
- Infrastructure Architect
- The Service Account user must be an:
Additional information
See SovLabs getting started: http://docs.sovlabs.com/latest/vmware-vra7x-plugin/getting-started/
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