Problem
After submitting an execution to OneFuse, the Job process status stays on “Initializing” even after the Upstream Provider job status has timed out.
This affects all OneFuse modules and job runs.
Cause
Reviewing the job engine log file located at /var/log/cloudbolt/jobengine.log shows an error similar to the following.
{"asctime": "2020-11-05 15:51:20,400", "levelname": "ERROR", "name": "jobengine.worker00", "message": "The CloudBolt license is in an invalid state: The license is expired."}
The OneFuse UI for updating a license does not affect the original license installed located at /var/opt/cloudbolt. The original license expiration date has passed causing the job engine to halt initialization on new executions.
Affected Versions
OneFuse v1.x
Workaround or Solution
Overview
Manually updating the license file located in /var/opt/cloudbolt is required along with the OneFuse UI License Update.
Obtain a new/updated License file from Cloudbolt Support
Contact your account management associate or submit a support request at http://support.cloudbolt.io to obtain an updated license
SCP the new License file to the OneFuse Installation
Log into the target OneFuse appliance using an SCP utility, such as WinSCP, Filezilla, Cyberduck, etc
Navigate to the /var/opt/cloudbolt directory
Rename the current license.bin file to license.bin-old
Upload the new license file and rename it to license.bin
Restart your OneFuse appliance
Validate new job executions
Submit a new execution from any upstream provider configured and confirm the job surpasses the “Initializing” state
Additional information
n/a
0 Comments