OneFuse Jobs Stuck at "Initializing"

Problem 

After submitting an execution to OneFuse, the Job process status stays on “Initializing” even after the Upstream Provider job status has timed out.

This affects all OneFuse modules and job runs.


Cause

Reviewing the job engine log file located at /var/log/cloudbolt/jobengine.log shows an error similar to the following.

{"asctime": "2020-11-05 15:51:20,400", "levelname": "ERROR", "name": "jobengine.worker00", "message": "The CloudBolt license is in an invalid state: The license is expired."}

The OneFuse UI for updating a license does not affect the original license installed located at /var/opt/cloudbolt. The original license expiration date has passed causing the job engine to halt initialization on new executions.


Affected Versions

  • OneFuse v1.x


Workaround or Solution

Overview

Manually updating the license file located in /var/opt/cloudbolt is required along with the OneFuse UI License Update.


Obtain a new/updated License file from Cloudbolt Support

  1. Contact your account management associate or submit a support request at http://support.cloudbolt.io to obtain an updated license

SCP the new License file to the OneFuse Installation

  1. Log into the target OneFuse appliance using an SCP utility, such as WinSCP, Filezilla, Cyberduck, etc

  2. Navigate to the /var/opt/cloudbolt directory

  3. Rename the current license.bin file to license.bin-old

  4. Upload the new license file and rename it to license.bin

  5. Restart your OneFuse appliance


Validate new job executions

  1. Submit a new execution from any upstream provider configured and confirm the job surpasses the “Initializing” state



Additional information

n/a


Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.