ServiceNow Connector - Account mapping not updating owner in vRA

Problem 

A requested VM from SNOW into vRA does not change the Requested For / Owner information even when you have configured the user mappings.


Cause

There are a couple of causes for this

  • FQDN for the mapped account was not provided
  • Invalid account or account does not exist
  • The account does not have appropriate permissions in vRA to deploy a VM
  • The account has never deployed a VM from vRA directly so is not in the IaaS Database


Affected Versions

  • This is not a SovLabs specific issue


Workaround or Solution

Overview

Below are some steps that you can take to make sure your user mappings are successful.

Checking user mappings in SNOW

  1. Check in the SovLabs SNOW User Mapping that you have entered an FQDN


  2. Check vRA to ensure the vRA User you have provided exists in vRA.  This covers both the invalid user account and the non existent account.
  3. Check the accounts permissions in vRA to ensure if has appropriate access to deploy a VM


Deploy a VM in vRA

If the user details are all correct, the account exists and the account has the appropriate permissions then the last item to check is to log into vRA and deploy a VM. 
The reason to do this is that the user is then inserted into the IaaS database.  Our module looks at the IaaS Database for the user and if it finds the user it will pass this information through, if it does not find the user in the database it will default to the connector account.

  1. Log into vRA with the user account that is not passing information through
  2. Select a deployment from the catalog and deploy a VM
  3. Optionally once deployed you can destroy that VM
  4. Test your SNOW Deployment again and validate the owner is updating as expected

Adding users to vRA IaaS Database (this is informational only)

  1. Use the built-in vRO action (System.getModule('com.vmware.library.vcac').getUserNames(iaasHost)) to view IaaS User table membership.
  2. Ask users to sign into vRA using the account ID. 
  3. A custom action can be created to add User ID's manually.


Additional information

SovLabs Connector : http://docs.sovlabs.com/latest/vmware-vra7x-plugin/connectors/service-mgmt/servicenow-connector/
SovLabs Connector walk through : https://support.cloudbolt.io/hc/en-us/articles/360046429731-Walk-through-Using-ServiceNow-Request-for-and-assign-ownership-in-vRA-using-Connector


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