Notifications not sending for some users when to or cc are templated

Problem 

When you have configured your TO or CC fields in your notifications to utilize {{ownerNameEmail}}, {{requestedByEmail}}, {{requestedForEmail}} some users are not receiving the notification.

When you check the vRO workflow for notifications you will see that there is no email address being published for each of the templated fields

What you would expect to see:

[2019-09-17 08:30:15.545] [I] Looking at vcachost: vcachostname
[2019-09-17 08:30:15.598] [D] Setting vmProperties[ownerNameEmail] = Email.Address@domain.name
[2019-09-17 08:30:15.601] [D] Setting vmProperties[requestedByEmail] = Email.Address@domain.name
[2019-09-17 08:30:15.604] [D] Setting vmProperties[requestedForEmail] = Email.Address@domain.name
[2019-09-17 08:30:15.605] [D]

What you do see:

[2019-09-18 13:56:19.190] [I] Looking at vcachost: vcachostname
[2019-09-18 13:56:19.226] [D] 


Cause

This issue occurs if the user that is making the request does not have an email address defined in AD and has not synced into vRO/vRA

Affected Versions

  • All


Workaround or Solution

Overview

Ensure that the requesting user account has a defined email address in Active Directory and it has sync'd to vRA/vRO. 
NOTE: Based on your organisation you will have to add the email address through your identity management master or directly into active directory.  

Where the email address is in Active Directory


Additional information

SovLabs Notifications : http://docs.sovlabs.com/latest/vRA/7.6/modules/platform-extensions/notifications/
SovLabs Template Engine : http://docs.sovlabs.com/latest/vRA/7.6/framework/sovlabs-template-engine/basics/intro/


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