The connection to vCenter Orchestrator server timed out - Failed to retrieve form from provider

Problem 

Attempting to modify LCM Profiles and Scripts, as well as perform Veeam File Level Restores or other SovLabs module catalog items fail with an error indicating "The connection to vCenter Orchestrator server timed out" or "Failed to retrieve form from provider".

Cause

This error is related to a default timeout setting configured inside vRA. The default timeout setting is 30 seconds

Affected Versions

  • vRA 7.3.1 | 7.4 | 7.5 | 7.6

  • SovLabs Plugin(s)
    • Veeam
    • Lifecycle Toolkit



Solution

Overview

Solution is modifying 2 settings inside the vRA appliance(s) which will increase the timeout

Modify the two property files

  1. Open an SSH connection to vRA using the root credentials and run these commands and make the requested edits to increase the timeout values in o11n-gateway and shindig-ui properties and restart the vcac-server.

  2. cd /var/lib/vcac/server/webapps/vcac/WEB-INF/classes/
  3. cp shindig.properties shindig.properties.`date +%m%d%Y`
  4. vi shindig.properties
  5. edit the line containing shindig.http.client.read-timeout-ms=150000  Change the number after ms= from 30000 to 150000, save and close. (thirty thousand to one-hundred-fifty thousand)

  6. cd /usr/lib/vcac/server/webapps/o11n-gateway-service/WEB-INF/classes/META-INF/spring/root
  7. cp o11n-gateway-service-context.xml o11n-gateway-service-context.xml.`date +%m%d%Y`
  8. vi o11n-gateway-service-context.xml
  9. edit the line that contains <property name="socketTimeout" value="#{vcoConfig['vco.socket.timeout.millis']?:30000}"/> change 30000 to 150000, save and close.

  10. service vcac-server restart

Repeat on all nodes if vRA is clustered, starting with any replica nodes.   Before restarting the Master node, in the vami, promote a replica to Master and wait for it to complete.  Once the original Master becomes a replica, then you can complete the restart on that node.

NOTE

When you run the service vcac-server restart command, this will restart vRA and will disrupt user access until the services come back up, usually about 15-20 minutes.


Additional information

vRealize Automation 7.4 Release Notes - https://docs.vmware.com/en/vRealize-Automation/7.4/rn/vRealize-Automation-74-release-notes.html

VMware Community Solution  - https://communities.vmware.com/thread/580839

VMware KB: https://kb.vmware.com/s/article/2127518



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