Duplicate Virtual Machine CI in ServiceNow

Problem 

When running ServiceNow Discovery and using the SovLabs ServiceNow CMDB module, duplicate VMware Virtual Machine Instance CIs are created after Discovery runs.


Cause

The SovLabs ServiceNow CMDB module writes the VMware Virtual Machine Instance CI to ServiceNow after provisioning, however the JSON template used to create the CI populated the Virtual Machine UUID into the wrong field in the CMDB. When the ServiceNow Discovery process runs it fails to find the existing CI when searching by the VM UUID and creates a new CI. 


Affected Versions

  • SovLabs ServiceNow CMDB module in SovLabs vRA Extensibility plugin versions up to and including 2019.5.0

Solution

Overview

This has been resolved in module revision 2019.6.0 so it is recommended to upgrade. However, if you are experiencing this issue you will also have to follow the below instructions to amend the JSON text to replace the text of "vcenter_uuid" with "vm_instance_uuid"

NOTE: This template UI also has another bug where modifications to the JSON template are saved, however when the Update ServiceNow CMDB Configuration dialog page is opened, the JSON in the JSON Template field reverts to the default. 

To work around this, you should make a copy of the JSON in a text editor and save it.  Make your edits there instead of in the Update form, and then copy/paste into the JSON Template field of the  Update SovLabs CMDB Configuration form in vRA.  It is worth considering saving the JSON templates in your own version control so changes can be tracked, and the JSON can be copied from there into the form.


STEPS:

  1. In vRA, open Deployments tab and find ServiceNow CMDB Configuration, select View Details
  2. Copy the JSON from the JSON Template field into a text editor (make sure you use a text editor and not MS word or any other editor that might add formatting)
  3. Replace all instances of "vcenter_uuid" with "vm_instance_uuid" in the JSON field. In this Default VM template there are two:
  4. Open deploments and find ServiceNow CMDB Configuration, select Update ServiceNow CMDB Configuration
  5. Paste the updated JSON template into the JSON Template field, replacing the contents of the field entirely.
  6. Click Submit (do not click SAVE) and wait for the Update request to complete (see the Deployments tab in vRA)

Additional information

SovLabs ServiceNow Module : http://docs.sovlabs.com/latest/vRA/7.6/modules/service-mgmt/servicenow-cmdb/


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