Remoter - RemoterResponse{exitCode=null, stdout='null', stderr='null'}

Problem 

When a SovLabs module is executed that runs a PowerShell scripts to perform an action on a Microsoft Endpoint (e.g. DNS, Microsoft AD), an error message is produced and the following line is returned in the debug vRO workflow before the error message: 

[2020-01-09 14:18:54.035] [D]    Return: DynamicWrapper (Instance) : [sovlabsRemoterResponse]-[class com.sovlabs.vra.remoter.RemoterResponse] -- VALUE : RemoterResponse{exitCode=null, stdout='null', stderr='null'}

Cause

The debug log is indicative of a customer environment or customer configuration issue. The module is for whatever reason not able to reach the destination Microsoft Endpoint. Remoter tries to reach the endpoint and gets the critical triple null response

RemoterResponse{exitCode=null, stdout='null', stderr='null'}

Affected Versions

  • SovLabs 2017.3.1 and onwards

Workaround or Solution

Overview

There are a number of areas to check. 

Microsoft Endpoint Configuration

  1. VMWare-Tools Connection Type, Hostname or Jump server / VM name as it appears in vCenter is Case Sensitive and needs to be typed exactly how it appears in vCenter (Not the FQDN of the server). 
  2. The temporary folder has been correctly set up
    1. The folder must exist. Best practice is to update your VM template and create a new folder and not use the default of "c:\windows\temp". 
    2. Read, Write, Delete permissions (Full control or modify permissions) for the folder have been granted to the service account (see additional information for links on permissions)

Customer Environment/External configuration Issues

  1. Check that the target Microsoft server is up and running and reachable from vRO (e.g. The server may have Windows updates and/or a reboot pending).
  2. For jump servers, make sure Remote Server Administration Tools (RSAT)  are present and installed for the modules required (DNS, IPAM, ADUC)
  3. For direct connection to the Domain Controller (DC), ensure AD Web Services are installed on all of the DC servers and running (This should be installed and running by Default on a DC). 

    Because permissions are generally stricter for Domain Controllers, using a jump server may be preferred.  Consult with your Windows domain administrator about which method makes sense in your environment.

  4. Failed authentication to server
    1. You will need a Windows service account with appropriate permissions to work with the server specified Microsoft Endpoint.

      Check with your Domain administrator to get an account created with appropriate permissions or local administrator rights depending on your company policies.

    2. Make sure the service account credentials are correctly entered in the SovLabs credentials for the appropriate Microsoft Endpoints.  Use the Manage Credential Configuration from the vRA catalog to update the account password. 

Test telnet to your endpoint / ESXi server

SovLabs have a telnet testing utility to test connectivity from your vRO server. The document can be found HERE

Check the minimum requirements to use VMWare-Tools 

Check your minimum connectivity requirements to your Jump Server or end server HERE

Additional information

SovLabs vCenter Endpoint Account Setup : https://support.sovlabs.com/a/solutions/articles/6000224098
Jump server / VMWare-Tools account setup : https://support.sovlabs.com/a/solutions/articles/6000226359
SovLabs Microsoft EndPoint Configuration (Jump Host / WinRM) : https://support.sovlabs.com/a/solutions/articles/6000223576
VMWare-Tools Jump Server connection requirements : https://support.sovlabs.com/a/solutions/articles/6000236402
SovLabs Telnet tester : https://support.sovlabs.com/a/solutions/articles/6000236592
VMWare-Tools Jump server minimum connection requirements : https://support.sovlabs.com/a/solutions/articles/6000236402


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