VMware 7.3.1 vRO Hotfix - vco-7.3.1.21692-11348925

Problem 

After installing the VMware Hotfix for vRA 7.3.1 with embedded vRO, the Sovlabs plugin fails to load property in vRO which halts all functionality of the Sovlabs product.

Cause

The hotfix provided by VMware performs a default java heap reverts the -xmx value for the java heap back to 512, which reduces the default value per our product requirements. Additionally, other external 3rd party plugins may be affected by this hotfix and could cause inadvertent issues during plugin load actions that can affect the Sovlabs plugin.

Affected Versions

  • vRA 7.3.1 using Embedded vRO

  • SovLabs Plugin Version (All)

Solution

Overview

The solution is two fold. With the first step being an adjustment on the Java Heap. And the second using the Force Plugin Reinstall option built into the vRealize Orchestrator Control Center.

Adjust the vRO Max Heap Size back to 768

  1. SSH as user root to the vRO server (e.g. SSH via PuTTy)
  2. Make a backup copy of setenv.sh file

    cp /var/lib/vco/configuration/bin/setenv.sh /var/lib/vco/configuration/bin/setenv.sh.bak
    
  3. Modify the setenv.sh file:

     Be sure to edit the setenv.sh in configuration/bin and not in app-server/bin. This file is specific to the vRO Configurator (vRO Control Center)

    vi /var/lib/vco/configuration/bin/setenv.sh
    
  4. Press the i key on the keyboard to edit the file
  5. Find the #MEM_OPTS= section and replace 512 with 768

    MEM_OPTS="\
    -Xms128m \
    -Xmx768m \
    -Xmn128m \
    -Xss256k \


  6. Press the esc key on the keyboard

  7. Type in :wq and press the Enter key to save the file
  8. Restart vRO Configurator Service:
  9. Repeat if you have more than one vRO (or vRA if using embedded vRO)

    service vco-configurator restart

Execute the Force Plugins Reinstall from vRealize Orchestrator Control Center

  1. Log into the vRO Control Center
    1. Embedded vRO Path: https://vrafqdn:8283/vco-controlcenter/
  2. Shutdown the vRO Server service by navigating to Start-Up Options and selecting STOP
  3. Navigate to the Monitor and Control section and select Troubleshooting
  4. Click the button for Force plug-ins reinstall
  5. Restart the vRO services


Verify the Sovlabs Plugin Inventory loads

  1. Log into the vRO using the Java Client
  2. Navigate to the Inventory tab


  3. Expand the SovLabs vRA Extensibility Modules


  4. If you see the folders populate below the module then the plugin loaded successfully


Additional information

If you experience any issues for this hotfix, please reach out to Sovlabs support at https://support.sovlabs.com.

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